Next tier won't unlock for me in Spearmint


I’ve tried using a different homepath, doesn’t unlock the next tier. I’ve already beat Tier 0. Tier 1 SHOULD be unlocked, but for some reason, it isn’t.

Programming three team CTF

Does the iamacheater command unlocked it?

I tested clearing Tier 0 on Windows, Linux, and OS X when testing the Spearmint 0.3 release and didn’t have an issue.


I’ll try iamamonkey instead. Nope, still doesn’t for me. Might be I used spmap too many times. & also, I found a glitch in 0.3 where if you devmap to a map, and spam give flight, it’ll give you infinite flight until the match is over.


iamamonkey command unlocks awards not levels, so it won’t unlock the next tier.


iamamonkey DOES unlock levels though. It says after you enter it is “All levels unlocked at rank 100”.


No it does not, the message was wrong.

Getting a power up adds more time you will have the power up. This is not a glitch.


What I mean is the flight stuff will disappear & it’ll never go away.


hmm, yeah it does. maybe the time wraps around to negative or something.


Could you also make it so that iamamonkey also unlocks all levels at Nightmare skill zturtleman?


uh, yeah I could but there is no reason to.


Well, it kinda makes sense because iamamonkey essentially means that you’re literally just really good, in the figurative sense.


I’ve made a modification to ui_gameinfo.c to unlock the levels at skill 5 when iamamonkey is entered. Needs some testing however. Here’s the link:!R0UgADTR!sg9IWfWuHIYH1hYvYqC-u-tkt1-DpovCd8NDEdJstk4
Updated the link to fix some minor layout/code errors in the new function.


By the way, it’s more convenient for myself and others to view the changes if you use git diff > mychanges.patch from the code repository and copy the contents of the file to That way no file needs to be downloaded and it’s visible what exactly you changed instead of the whole file.

That said, I don’t see any reason to change this in mint-arena even after your explanation that monkey means really good in a literal figurative sense. It’s just a command name, it’s not like it means you’re a cheater or monkey by running it.


I actually didn’t know those even existed zturtleman! EDIT: Here’s the gist for the code zturtleman:


that’s a step in the right direction, but it’s still the whole file instead of git diff code/q3_ui/ui_gameinfo.c output.

so you copied and pasted the existing code, changed the function name, and changed three “1” to “5”? I’m not really sure why you’re showing me this.


It should function identically for that reason, but instead of unlocking the levels at I Can Win, it’ll unlock them at Nightmare.


yes that is correct.


But does the function work though? Or does it need more testing/reworking?


To be blunt, test and debug your own code. If you have the time and inclination to debug the issues you find using Spearmint that would be helpful. If you really want to push yourself, start solving other peoples Quake 3 related or general programming issues too.

If you’re absolutely stuck for days on something you’re programming and want to ask for help on specific code that’s understandable. I should be a last resort resource.


I’m not really sure where the code for the main command for iamamonkey is anyway, so it probably doesn’t work right now. But, if I code it right, then I can be able to fork your repo & add my code changes to it. P.S. I wonder how I can keep a repo updated with remote tracking, anyway?